O que é algoritmo? Visão geral e técnica

COMPARTILHAR:

Introdução

Primeiramente, vamos falar do conceito matemático e computacional de algoritmo.

Dessa forma, se formos indagados sobre o que é algoritmo?

Então podemos facilmente dizer que é uma sequencia finita de ações executáveis, para solucionar algum tipo de problema.

Características:

CURSO GRATUITO DE DESENVOLVIMENTO WEB
  • Finito.
  • Solucionar problemas.
  • Passos bem definidos e claro entendimento.
  • Antecipar falhas.
  • Resolver o que foi proposto a solucionar.

Portanto, de forma mais geral, algoritmos tem como exemplo a receita de bolo, que é uma sequência de passos para chegar a um determinado objetivo, nesse caso, o bolo.

Então algoritmos podem repetir passos, fazer interação como fazer comparações ou lógica.

Dessa forma, pode fizer que algoritmos com erros de implementação não resolverão problemas, por isso é muito importante que seja escrito corretamente.

O que é algoritmo? Exemplo prático

Antes de tudo, vamos voltar no tempo, é muito importante saber que o primeiro algoritmo a ser processado por uma máquina, foi escrito por Ada Lovelace. Bem como a máquina analítica que era de nada mais e nada menos que Charles Babbage.

Dessa forma, um software de computador é em sua essência um algoritmo que diz ao computador a sequencia e a ordem de passos exata que eles devem ser executados.

CURSO GRATUITO DE PYTHON

Portanto, para que essa interação aconteça, programadores escrevem algoritmos de forma lógica.

Assim, possibilitando a conversa homem e máquina.

Então um exemplo bem básico para fixarmos o que é algoritmo, é fazer a média dos alunos, coletando suas notas e dizendo se ele foi aprovado ou reprovado.

Exemplo de Algoritmo:

var

NOTA1, NOTA2, NOTA3, NOTA4, MEDIA

inicio

// Seção de Comandos

ESCREVA (“DIGITE A PRIMEIRA NOTA: “)

LEIA (NOTA1)

ESCREVA (“DIGITE A SEGUNDA NOTA: “)

LEIA (NOTA2)

ESCREVA (“DIGITE A TERCEIRA NOTA: “)

LEIA (NOTA3)

ESCREVA (“DIGITE A QUARTA NOTA: “)

LEIA (NOTA4)

MEDIA = (NOTA1 + NOTA2 + NOTA3 + NOTA4) / 4

SE MEDIA <= 6,9 ENTAO

ESCREVA (“A MEDIA DO ALUNO FOI: “, MEDIA)

ESCREVA (” – ALUNO REPROVADO “)

FIMSE

SE MEDIA >= 7 ENTAO

ESCREVA (“A MEDIA DO ALUNO FOI: “, MEDIA)

ESCREVA (” – ALUNO APROVADO “)

FIMSE

fimalgoritmo

Leia também: Os 4 Melhores Livros de Java para Iniciantes

Blog Programadores Depre

Conclusão

Portanto, com o passar do tempo a criação e o entendimento sobre algoritmos fica muito simples para os programadores.

Porém para que isso aconteça é preciso praticar bastante.

hostinger banner

Então, como tudo na vida, o melhor ensino é a prática, procure por exercícios de lógica de programação e faça-os.

Sendo assim, entende-se que programadores são lapidados e criados na prática.

Então, se você é estudante de programação, vou deixar alguns links de conteúdos GRATUITOS para você começar a estudar ainda hoje:

COMPARTILHAR:
brayan

Brayan Monteiro

Bacharel em Sistemas de Informação pela Faculdade Maurício de Nassau e desenvolvedor PHP. Além de programador, produzo conteúdo e gerencio blogs. Sou especialista em desenvolvimento de software, SEO de sites e em negócios digitais.